The Temptress

Message
Author
LPGC
Installer
Posts: 4684
Joined: Wed Sep 29, 2010 6:01 pm
Location: Yorkshire
Contact:

Re: The Temptress

#61 Post by LPGC »

I reckon the stepper should work fine unless you're talking mega boost levels. I can't see there being a boost leak or the boost preventing the stepper movement. Haven't seen many turbo'd engines with mixer systems and closed loop / steppers though.

Edit - I'd add to that and say that when the engine is under boost really you want to be running a rich mixture but a closed loop mixer LPG system won't know it's under boost it will instead just see RPM and maybe TPS.

You've done a turbo'd mixer engine before, I haven't checked your thread on that so I'll ask was that open or closed loop?
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240

Gilbertd
Advanced Member
Posts: 8859
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: The Temptress

#62 Post by Gilbertd »

But if using a Leo you can set a fixed actuator opening above certain revs or TPS signal. So you should be able to set it rich when under boost.
96 Saab 900XS, AEB Leo, sold
93 Range Rover 4.2LSE, Lovato LovEco, sold
97 Range Rover 4.0SE, multipoint, sold
98 Ex-Police Range Rover 4.0, AEB Leo, daily motor
96 Range Rover 4.6HSE Ascot, AEB Leo, my spare


Proud member of the YCHJCYA2PDTHFH club.

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#63 Post by robertXX »

Good point Gilbert .

in the past , when i have used a mixer and a fixed setting power valve, i have found that if i have the full throttle mixture right from tickover to 3500 , and from 4500 to 7000, then it goes lean between 3500 and 4500 . i am hoping i can use the valve to run 14.7 all the way through and so avoid the lean patch .

However , if i can set the leo to use the stepper to target a higher richer voltage on full throttle , and still be closed loop , then that would be best .
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

LPGC
Installer
Posts: 4684
Joined: Wed Sep 29, 2010 6:01 pm
Location: Yorkshire
Contact:

Re: The Temptress

#64 Post by LPGC »

Most normally aspirated engines go rich open loop at high loads above around 3000rpm, most turbo'd engines go open loop under those same conditions but also at any rpm under boost... So there's that difference. But yeah it's a good point and there's less reason to go as rich on LPG as on petrol anyway.
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#65 Post by robertXX »

well poxy pox , my leo wont talk to my pc . using a made up circuit board as the interface ,from the diagram .

windows 7 ,serial to usb adaptor .and tried w98 and xp compatability .
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#66 Post by robertXX »

Image
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Brian_H
Intermediate Member
Posts: 2569
Joined: Mon Jan 23, 2012 12:21 pm
Location: Milton Keynes

Re: The Temptress

#67 Post by Brian_H »

Are you sure the Leo actually has the Leo firmware installed and not one of the others flashed onto it? Richard has mentioned one of his doesn't match the label on the box as such, and he has to use one of the other bits of software to connect to it?

Its not unknown for the usb to serial convertors to be an issue as well, general theme with those is some appear better than others, Does the serial port show up in device manager with a low numbered port and no driver issues?

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#68 Post by robertXX »

yes brian ,port comes in at com8. also the box has the leo sticker , but may mean nothing of course .
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Brian_H
Intermediate Member
Posts: 2569
Joined: Mon Jan 23, 2012 12:21 pm
Location: Milton Keynes

Re: The Temptress

#69 Post by Brian_H »

Com8 probably won't work with software of that age. Set it to something between com1 and com4. Whatever is free. Preferably com1. You can do that from device manager

Gilbertd
Advanced Member
Posts: 8859
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: The Temptress

#70 Post by Gilbertd »

Com 8 definitely won't work, it needs to be lower than 4, preferably Com 1 as Brian says. USB to serial adapters using the FTDI chipset usually work, those using the Prolific chipset very rarely do. Just because the label says Leonardo, it could equally have OMVL Millenium, Bigas Regal or a number of others (although these are the most common ones) and you need the matching software.
96 Saab 900XS, AEB Leo, sold
93 Range Rover 4.2LSE, Lovato LovEco, sold
97 Range Rover 4.0SE, multipoint, sold
98 Ex-Police Range Rover 4.0, AEB Leo, daily motor
96 Range Rover 4.6HSE Ascot, AEB Leo, my spare


Proud member of the YCHJCYA2PDTHFH club.

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#71 Post by robertXX »

excelllent info thank you chaps .


mine appears ot be a prolific..


https://alltroniccomputer.com.sg/produc ... ic-chipset


i have charged up an old xp with serial port laptop , so will try that today . is there anything i would see inside the box to tell me its s/w type ?


regards
robert
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Brian_H
Intermediate Member
Posts: 2569
Joined: Mon Jan 23, 2012 12:21 pm
Location: Milton Keynes

Re: The Temptress

#72 Post by Brian_H »

No, it could be flashed with any of the software, its a case of try each one till you get one that works, but address the serial port first. I'd expect the prolific one to at least connect, even if it falls over aftewards, but not whilst its set to com8.

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#73 Post by robertXX »

ok dokey will do that this morning after my lidls run .
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Gilbertd
Advanced Member
Posts: 8859
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: The Temptress

#74 Post by Gilbertd »

Laptop with a proper serial port should work perfectly. The Leo needs to be powered (ignition on or engine running) to connect to it but you'll know when you're connected as the first thing you'll see is a pop up box saying ECU Download In Progress.
96 Saab 900XS, AEB Leo, sold
93 Range Rover 4.2LSE, Lovato LovEco, sold
97 Range Rover 4.0SE, multipoint, sold
98 Ex-Police Range Rover 4.0, AEB Leo, daily motor
96 Range Rover 4.6HSE Ascot, AEB Leo, my spare


Proud member of the YCHJCYA2PDTHFH club.

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#75 Post by robertXX »

yup i had it connected to a battery in the cave , and i had the ecu download box come up , but then it failed.
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#76 Post by robertXX »

Ok !

1) W7 laptop...change to com2 .no luck
2)copy leo files to a 3.5" floppy ,then another floppy cos first was too small , put files on w98 laptop.
3) try to open leo , not working .
4)download leo s/w from lpg shop onto vista laptop ,change to com 1 , no luck .
5) copy leo s/w onto cdr disc , and put into w98 laptop .run setup ,.
6) try w98 laptop , with new sw , and serial port/ lead on com1 .no luck .

gave up . :(


need different usb serial adaptor or different s/w or my interface board doesnt work or the leo is dead . or all of them !
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#77 Post by robertXX »

IMG_2850.JPG
IMG_2850.JPG (527.29 KiB) Viewed 4892 times

oh ! it may be a bit old too....
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

LPGC
Installer
Posts: 4684
Joined: Wed Sep 29, 2010 6:01 pm
Location: Yorkshire
Contact:

Re: The Temptress

#78 Post by LPGC »

Is the serial port set to use standard settings (baud rate etc)?

No IRQ clash issues for the serial port in W98?

Powering a laptop from the same car battery that powers whatever you're trying to connect to (AEB175) can cause earth loop type problems.
Full time LPG installer
Servicing / Diagnostics / Repairs to all systems / DIY conversion kits supplied with thorough tech support
Mid Yorkshire
2 miles A1, 8 miles M62,
http://www.Lpgc.co.uk
Twitter https://twitter.com/AutogasSimon
07816237240

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#79 Post by robertXX »

yup 9600 baud ..puter on house leccy , no clashes.
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Brian_H
Intermediate Member
Posts: 2569
Joined: Mon Jan 23, 2012 12:21 pm
Location: Milton Keynes

Re: The Temptress

#80 Post by Brian_H »

The Millenium and pegaso software can be got from https://tinleytech.co.uk/lpg-software/

I'd give them a try if you haven't already done so.

Did you have another AEB 175 somewhere? Which might allow you to rule out the lead and loom?

Post Reply