The Temptress

Message
Author
Gilbertd
Advanced Member
Posts: 8859
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: The Temptress

#121 Post by Gilbertd »

Not sure and it's on the laptop tucked away in the car. But, having had a look, I've got versions 2.2.3, 2.3.0, 3.1.0 and 4.1.1 on a hard drive and suspect it is version 3.1.0 that I'm running as it's also on a USB stick so I probably used that to put it on the laptop. These are the Leonardo ones and I've also got an unnumbered version of the OMVL Millennium software, version 3 of the Bigas Pegaso software, an unnumbered version of the Romano 175 software and the Zavoli Regal software. If I find your cable works, I'll send you a full set so you can have a play with them.
96 Saab 900XS, AEB Leo, sold
93 Range Rover 4.2LSE, Lovato LovEco, sold
97 Range Rover 4.0SE, multipoint, sold
98 Ex-Police Range Rover 4.0, AEB Leo, daily motor
96 Range Rover 4.6HSE Ascot, AEB Leo, my spare


Proud member of the YCHJCYA2PDTHFH club.

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#122 Post by robertXX »

is there a disagreement between the two diagrams here ,re pins 7 and 8 ?





Image





Image
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Gilbertd
Advanced Member
Posts: 8859
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: The Temptress

#123 Post by Gilbertd »

Don't think so, see the block diagram here https://www.maximintegrated.com/en/prod ... AX232.html
96 Saab 900XS, AEB Leo, sold
93 Range Rover 4.2LSE, Lovato LovEco, sold
97 Range Rover 4.0SE, multipoint, sold
98 Ex-Police Range Rover 4.0, AEB Leo, daily motor
96 Range Rover 4.6HSE Ascot, AEB Leo, my spare


Proud member of the YCHJCYA2PDTHFH club.

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#124 Post by robertXX »

i am prob being stupid , but isn't pin 7 , "T2 out" on the block dia , and pin 7 "RX" on the lpg diagram ?
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Gilbertd
Advanced Member
Posts: 8859
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: The Temptress

#125 Post by Gilbertd »

Yes, it's out of the chip and in (Rx) at the RS232 connection.
96 Saab 900XS, AEB Leo, sold
93 Range Rover 4.2LSE, Lovato LovEco, sold
97 Range Rover 4.0SE, multipoint, sold
98 Ex-Police Range Rover 4.0, AEB Leo, daily motor
96 Range Rover 4.6HSE Ascot, AEB Leo, my spare


Proud member of the YCHJCYA2PDTHFH club.

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#126 Post by robertXX »

not understanding that , but hey that's normal for me :)


did a quick test of the laptops serial port ,by plugging in my innovate lm1 , and it connected on com 1 no problemo .


Image



before i posted your box i had a look gilbert ,and its 2005 , so 4 years newer than mine .the chip inside was labelled the same as mine on the white sticker though .



regards
robert
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Gilbertd
Advanced Member
Posts: 8859
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: The Temptress

#127 Post by Gilbertd »

Initial test using your lead (with it's funny non-standard plug so had to do a bit of poking wires in holes), my computer and connected to my ECU gives, ECU Download followed by Link Not Possible. So that seems to point towards the interface. It's not using the MAX232 but the LT1081CN, which should work as it is just another RS232 to TTL converter chip but for some reason it doesn't. Linking the In and Out and trying to use Terminal to send back to itself doesn't work either so I suspect it is dead.
96 Saab 900XS, AEB Leo, sold
93 Range Rover 4.2LSE, Lovato LovEco, sold
97 Range Rover 4.0SE, multipoint, sold
98 Ex-Police Range Rover 4.0, AEB Leo, daily motor
96 Range Rover 4.6HSE Ascot, AEB Leo, my spare


Proud member of the YCHJCYA2PDTHFH club.

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#128 Post by robertXX »

right ! tinley lead ordered !
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#129 Post by robertXX »

Well as usual i have made life hard lol.

Went to put the molex plug back on my ecu lead , ,but only had a few mm of lead in the plug , so stripped off the insulation, blobbed some solder on there , and then went to connect the lead ,....


oh :(

yup , like a total noodle i had stripped off the colours .

so can you tell me , is this right ?

Image


thanks
regards
robert
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Gilbertd
Advanced Member
Posts: 8859
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: The Temptress

#130 Post by Gilbertd »

Just checked mine. You've got the Pink and Pink/Black swapped over. Looking at it from the back of the socket as in your pic, it goes Pink, White/Red, Black, Pink/Black.
96 Saab 900XS, AEB Leo, sold
93 Range Rover 4.2LSE, Lovato LovEco, sold
97 Range Rover 4.0SE, multipoint, sold
98 Ex-Police Range Rover 4.0, AEB Leo, daily motor
96 Range Rover 4.6HSE Ascot, AEB Leo, my spare


Proud member of the YCHJCYA2PDTHFH club.

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#131 Post by robertXX »

Coolio. I will change em.
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Brian_H
Intermediate Member
Posts: 2572
Joined: Mon Jan 23, 2012 12:21 pm
Location: Milton Keynes

Re: The Temptress

#132 Post by Brian_H »

Out of interest, would this work?
https://www.ebay.co.uk/itm/304000267470

I suspect the voltage input isn't what you want (spec isn't very clear but I think it wants a 5v feed?) but would imagine that can be worked around.

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#133 Post by robertXX »

that does look viable Brian , however i have now purchased the tinley tech one .
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Brian_H
Intermediate Member
Posts: 2572
Joined: Mon Jan 23, 2012 12:21 pm
Location: Milton Keynes

Re: The Temptress

#134 Post by Brian_H »

Thats probabbly a better bet, and hopefully has a connector thats suitable too.

Gilbertd
Advanced Member
Posts: 8859
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: The Temptress

#135 Post by Gilbertd »

That eBay board looks to be the same circuit without the 7805 voltage regulator so would work if you didn't feel like building one. Come to that, a USB UART board will work on a lot of systems too.
96 Saab 900XS, AEB Leo, sold
93 Range Rover 4.2LSE, Lovato LovEco, sold
97 Range Rover 4.0SE, multipoint, sold
98 Ex-Police Range Rover 4.0, AEB Leo, daily motor
96 Range Rover 4.6HSE Ascot, AEB Leo, my spare


Proud member of the YCHJCYA2PDTHFH club.

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#136 Post by robertXX »

Brian_H wrote: Mon Jul 12, 2021 9:30 pm Thats probabbly a better bet, and hopefully has a connector thats suitable too.

it has the ampseal connector , so i just have to rewire it to my molex i bought, if i can work out which colour on the amp means what ,they are not the same colours as the molex .
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Gilbertd
Advanced Member
Posts: 8859
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: The Temptress

#137 Post by Gilbertd »

I found a picture of the adapter lead on the AEB website (but can't find it again) but that showed the power and ground at each end with the data lines in the middle.
96 Saab 900XS, AEB Leo, sold
93 Range Rover 4.2LSE, Lovato LovEco, sold
97 Range Rover 4.0SE, multipoint, sold
98 Ex-Police Range Rover 4.0, AEB Leo, daily motor
96 Range Rover 4.6HSE Ascot, AEB Leo, my spare


Proud member of the YCHJCYA2PDTHFH club.

Gilbertd
Advanced Member
Posts: 8859
Joined: Wed Apr 09, 2008 10:00 am
Location: Peterborough

Re: The Temptress

#138 Post by Gilbertd »

96 Saab 900XS, AEB Leo, sold
93 Range Rover 4.2LSE, Lovato LovEco, sold
97 Range Rover 4.0SE, multipoint, sold
98 Ex-Police Range Rover 4.0, AEB Leo, daily motor
96 Range Rover 4.6HSE Ascot, AEB Leo, my spare


Proud member of the YCHJCYA2PDTHFH club.

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#139 Post by robertXX »

thank you Gilbert that's very handy .
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

robertXX
Member
Posts: 414
Joined: Sat Dec 18, 2010 9:45 am

Re: The Temptress

#140 Post by robertXX »

quick update , i rewired the new lead , and bingo it talks to the leo .:) also a kind chap let me play with a millenium , and it talks to that as well .bonus :)

also put the inj stubs in ..


Image



and sweated the manifold on this afternoon ..


Image


oh incidentally , is there any functional difference between the two ecu's ?


regards
robert
"The Temptress" thread..... https://forum.retro-rides.org/thread/215234/temptress
'Medusa" thread .....https://www.rodsnsods.co.uk/threads/medusa.206057/

Post Reply