Six years and 130k miles mgzt

Post Reply
Message
Author
minimutly
New member
Posts: 73
Joined: Sat Aug 31, 2013 3:36 pm

Six years and 130k miles mgzt

#1 Post by minimutly » Sun Dec 01, 2019 9:24 pm

Hello all, it's been a while. In 2013 I fitted a brc sequent system to a newly purchased 40k miles mgzt. Now it's done 170k :)
The system wasn't fitted with flashlube, I put a torroid tank in the boot, solenoid on the lower front bulkhead (you can sometimes feel the click under your right foot), vaporiser on the upper bulkhead squeezed between the strut and the inlet manifold. I don't recall whether I removed the manifolds to fit the spuds. Oh, I pulled the plugs, checked them and gapped them down.
In the years I've had it the only issue up to now has been the front solenoid - coil failed, probably because of the crud that hits it, and a failed ht pencil type coil at 100k. Before I diagnosed the coil I bought a set of plugs (extravagant I know but that's me :lol: ), the originals had worn a bit, but looked very good. I changed the gas and liquid filters at the same time.
So here we both are, I expected it to do 100k, itas surpassed all my expectations. However, we now have an issue, well two really. The second issue is a question on transplanting the system to a 5 cylinder (maybe a Volvo t5). But the first issue is a starting problem on petrol. I'll post it on the problems section, but essentially it seems to be leaking gas into the engine, or maybe injecting gas and petrol. If I'm out of gas, or the car sits for a week it's fine. I have changed all the injectors with new.
Bye for now,
Huw

Post Reply