Page 2 of 2

Re: Zavoli Alisei momentarily cutting out / switcing to petrol on moderate acceleraton

Posted: Sun Jun 21, 2020 9:13 pm
by LPGC
The weak setting may have improved things.

By hiccup do you mean interface connection problems, rpm detection problems and/or drive-ability problems? Connection problems and rpm detection problems can seem to come and go on these systems and rpm detection problems can cause drive-ability problems.

It may be a bit early to feel relieved of hiccups, hopefully not!

Misfires can also cause hiccups. If the mixture is too rich you're likely to get a hiccup and by entering a lower reference pressure in software you'll have effectively leaned the mixture a little. A leaner mixture also implies a lower ginj, connection issues generally occur at high ginj's.

Pleased to read your promising results.

Re: Zavoli Alisei momentarily cutting out / switcing to petrol on moderate acceleraton

Posted: Sun Jun 21, 2020 9:17 pm
by danci1973
Day 2 of 'no hiccop'. I did some casual driving over the day and then a 'dedicated test drive' of about 100 kilometers...

I'm not popping the champagne just yet, but I will put one in the cooler. :D

Re: Zavoli Alisei momentarily cutting out / switcing to petrol on moderate acceleraton

Posted: Sun Jun 21, 2020 9:29 pm
by LPGC
Very good!

Did you make any changes to extra injection filtering etc?

Re: Zavoli Alisei momentarily cutting out / switcing to petrol on moderate acceleraton

Posted: Sun Jun 21, 2020 10:02 pm
by danci1973
LPGC wrote:
Sun Jun 21, 2020 9:13 pm
By hiccup do you mean interface connection problems, rpm detection problems and/or drive-ability problems? Connection problems and rpm detection problems can seem to come and go on these systems and rpm detection problems can cause drive-ability problems.
I meant the initial problem of LPG momentarily switching off / to petrol. The laptop to ECU connetion did occur once (I think).
It may be a bit early to feel relieved of hiccups, hopefully not!

Misfires can also cause hiccups. If the mixture is too rich you're likely to get a hiccup and by entering a lower reference pressure in software you'll have effectively leaned the mixture a little. A leaner mixture also implies a lower ginj, connection issues generally occur at high ginj's.

Pleased to read your promising results.
I will try to improve the map a little, but will need a helping hand for that, so that's coming some time in the future.



LPGC wrote:
Sun Jun 21, 2020 9:29 pm
Very good!

Did you make any changes to extra injection filtering etc?
Compared to the initial setup (from the installer), I probably did - I did experiment with that setting, but I didn't record every single change I made. I believe the slider was initially fully to the left whereas I've set it 3 places to the right.

But if you meant from my last report on Thursday - no, the only change I made was the 'Type of revolution signal' -> 'Weak' (and gas pressure from 1.5 to 1.4 bar).

Re: Zavoli Alisei momentarily cutting out / switcing to petrol on moderate acceleraton

Posted: Fri Jun 26, 2020 9:28 pm
by danci1973
Well, it's been a couple of days and I've put about 1500 km on the car without any (LPG related) issue whatsoever. I guess I'm ready to call it 'a success' and pop that proverbial champagne... :)

Thank you very much for your help, Simon, it's been very valuable.

Re: Zavoli Alisei momentarily cutting out / switcing to petrol on moderate acceleraton

Posted: Mon Jun 29, 2020 8:03 am
by LPGC
You're welcome

Re: Zavoli Alisei momentarily cutting out / switcing to petrol on moderate acceleraton

Posted: Thu Nov 12, 2020 11:57 pm
by Bobby B.
Hello ,
I have a similar problem with the system going through warm phase but not making the switch from petrol to LPG. I started troubleshooting and the problem is the LPG tank solenoid valve. This was happening on full tank of LPG and I suspect it was over filled and the higher pressure in the tank was causing the valve body being unable to slide open. To confirm this the Solenoid Coil was hot to the touch. I tapped the solenoid valve with a hammer and it freed it up. I am awaiting new parts to see if this is the absolute fix. Anyhow, just something to consider maybe your tank solenoid valve is sticking caused by debris as it you describe a half tank situation. My car 2012 Caprice PPV 6.0 liter V-8.
Good luck,
Bobby B.