Search found 87 matches

by rob99
Mon Feb 11, 2019 5:54 pm
Forum: General Discussion
Topic: Want a New 4x4
Replies: 3
Views: 339

Want a New 4x4

Hi All It's been a long time since I have been on here :shock: My 1995 3.5 V6 Shogun is still running ok at 160,000 miles with 40k on LPG but it's time for a change (sick of welding!!!) Been looking around but haven't really made my mind up what I want. Looked at Diesels but most of the ones I can a...
by rob99
Thu May 15, 2014 6:45 am
Forum: General Discussion
Topic: Pressure drop - how much power does a Zavoli Zeta-S support?
Replies: 4
Views: 714

Re: Pressure drop - how much power does a Zavoli Zeta-S supp

Hi I have a similar issue with my Zeta S, which I posted a couple of weeks ago. It's fitted to a 208 BHP V6 Shogun. On full chat it's started to drop the gas pressure down to about 1.05 bar and on the overrun from high rpm rises to 3+ bar. Took it apart and everything looks to be fine, no @!## and t...
by rob99
Tue Apr 29, 2014 6:45 am
Forum: Having Problems ?
Topic: How Does A Vaporiser Work?
Replies: 3
Views: 693

Re: How Does A Vaporiser Work?

Hi Rossko Thanks for the reply. I checked the rubber seal on the control valve and it seemed to be ok. There was a bit of rubber seal hanging off on the water gasket side where the liquid gas entry is, but it did look to be sealing. If it was leaking here then it would of leaked into the coolant sys...
by rob99
Mon Apr 28, 2014 9:19 pm
Forum: Having Problems ?
Topic: How Does A Vaporiser Work?
Replies: 3
Views: 693

How Does A Vaporiser Work?

Evening As some of you know I have been having issues with my vaporiser not controlling the gas pressure as it should. Took it apart to have a look (It's a Zeta S) and I think I have the gist of it but could use some help. As I see it there is a big spring with a diaphragm pushing on a lever which l...
by rob99
Fri Apr 25, 2014 8:40 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Fiited My New King ECU

Fitted a new King (AEB2568D) and it has cured the power loss without the laptop connected. The Shogun definitely runs better than ever and is much smoother. Perhaps the old ECU was always playing up. Still got the Gas pressure issue. I have got a new 8mm solenoid valve to fit tomorrow so will elimin...
by rob99
Thu Apr 24, 2014 6:02 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Hi Tubbs

Thanks for the reply.

I'll see if I can get a King ecu tomorrow.

Do you think the duff ecu could be reporting the odd gas pressure readings wrongly or does it look like the regulator is also knackered?

Ta Rob
by rob99
Wed Apr 23, 2014 9:57 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Ta Mate

Just what I wanted to hear.

Have you ever come across the issue with ECU's behaving when connected to a laptop but playing up when disconnected?

Ta Rob
by rob99
Wed Apr 23, 2014 9:19 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Ta Tubbs I thought I'd been excommunicated :D Was that Yes to you are on holiday, if so I hope your gas system didn't throw a wobbly :D Looks like I'm stumping up nearly £200 to sort this pile of scrap. Can I just plug my existing loom into the King ECU? I believe I can configure the ECU to fire bot...
by rob99
Wed Apr 23, 2014 8:26 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

It's a bit quiet in here this week, is everyone on holiday?

is a King ECU a direct replacement? Will it work with the early AEB changeover switch and do they support Matrix injectors?

Rob
by rob99
Tue Apr 22, 2014 8:39 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Hi Gents Been having a look around to see if anyone else has had this kind of issue and found this by Gibertd (Wasn't there someone on here a few months ago that replaced a dead or dying OMVL ECU with a King and found it identical except for different firmware (meaning it needed different software) ...
by rob99
Mon Apr 21, 2014 4:46 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Hi This is now doing my head in!!!!! Ran around with a multi-meter plugged in to various places. 1. 5v supply to map sensor does not change when the power loss occurs. 2. Ground wire to the map sensor does not change. 3. One sense (not sure if it's the vacuum or gas pressure) rises from about 2.3v t...
by rob99
Mon Apr 21, 2014 3:05 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Hi Simon Just gad a look at the acquisition I ran with it at 1.5 bar and the max pressure on the overrun was 3.2 bar. Had a look at some previous saved graphs and the gas pressure stayed quite stable at all rpm, so it does look like the regulator is goosed. What the minimum opening time for Matrix X...
by rob99
Mon Apr 21, 2014 12:46 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Hi Simon Thanks for the reply. I had a play again this morning. I upped the idle gas pressure to 1.5 bar and autocalibrated and it seemed to hold the pressure better at high revs/load. The gas pressure rises on the overrun when the system goes into cutoff mode. Is this correct or should it be able t...
by rob99
Sun Apr 20, 2014 1:32 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Hi Brian

Thanks for the tip. I have checked the connections but I'll go through them all again and remake the connections.

Just been down the shop and it ran fine??

Thanks Rob
by rob99
Sat Apr 19, 2014 3:58 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

OK Ran round this afternoon with the laptop connected and logging. Didn't miss a beat. Pulled the USB lead while driving and it started playing up. Without stopping plugged the USB lead back in and still got the problem. Opened the Zavoli software and the issue stopped. Don't know whether it's a coi...
by rob99
Sat Apr 19, 2014 12:09 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Hi Measured the %v at the map sensor and got 5.03v. ECU case to battery negative 0.02v Drove around for half and hour with laptop connected and disconnected and the bloody thing ran faultlessly!!!!!! Ran acquisition while driving (see below) and the indicated gas pressure is all over the place. Is t...
by rob99
Sat Apr 19, 2014 8:46 am
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Hi Simon Thanks for the tips. I'll check the 5v, I've got loads of regulators at work so I can fit one if incorrect. I haven't checked the earth to the ECU, I assumed the ground wire would be sufficient. The LPG system came off a Shogun I bought off Ebay. The Matrix injectors were fitted, Matrix is ...
by rob99
Thu Apr 17, 2014 6:51 pm
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Hi Rosskp Spoke to the guy at LPG Shop and he says they will replace it as it is only 9 months old. He also said he hadn't seen a Zeta S fail this early in it's life. Good job I aren't taking the caravan away over the BH because I can't get one until late next week. Could anything else cause this ki...
by rob99
Thu Apr 17, 2014 9:38 am
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Morning Chaps Got the Shogun and van back home yesterday, was still losing power and cylinders every time I switched to gas. Not many petrol stations in the Peak District so it was fun watching the gauge go down with only a 5 gallon tank :shock:. Isn't very economical with a 1.8 ton van on the back!...
by rob99
Tue Apr 15, 2014 10:47 am
Forum: Having Problems ?
Topic: Bl--dy Typical
Replies: 31
Views: 2508

Re: Bl--dy Typical

Hi Rossko I checked the regulator and it was hot to the touch and when I had the laptop connected the temp never changed, on the other hand it didn't play up when I had it connected. I connected up this morning and from cold the reg temp rose slowly to operating temp as normal. One thing I noticed w...