LPG Forum


All times are UTC



Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Jul 19, 2013 4:01 pm 
New member

Joined: Fri Dec 17, 2010 5:23 pm
Posts: 14
Location: Swindon
Hi had a problem recently which turned out to be a split pipe near the gas input. Had this fixed now but when trying to fill up with gas I got about 30p (a pipeful) then stop...
Is there a tank inlet valve that could be stuck? If so how do i release it?
The system is Milano.

Thanks


Top
 Profile  
 
PostPosted: Sun Jul 21, 2013 8:53 am 
Intermediate Member

Joined: Wed Apr 09, 2008 9:00 am
Posts: 6836
Images: 0
Location: Peterborough
There's a non-return valve in the filler and another in the inlet to the tank, the tank one might be stuck. Some multivalves have a manual valve on both the inlet and outlet, has it been shut off while the pipe was being replaced and not turn on again?

_________________
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.


Top
 Profile  
 
PostPosted: Sun Jul 21, 2013 11:30 am 
New member

Joined: Fri Dec 17, 2010 5:23 pm
Posts: 14
Location: Swindon
The valves weren't turned off. The filler has a ball bearing type NRV which works ok. Is the tank NRV likely to be the same? If so do I remove the pipe and push the ball bearing on the tank to free it? The tank is empty so maybe the NRV failed due to no pressure in the tank to keep the ball bearing in place.


Top
 Profile  
 
PostPosted: Sat Jul 27, 2013 3:57 pm 
New member

Joined: Fri Dec 17, 2010 5:23 pm
Posts: 14
Location: Swindon
The NRV in the tanks was sticking. Couldn't even blow through it. Now cleared that problem and have gas in the tank.
Unfortunately now another problem....
The outlet valve/solenoid on the tank isn't working.
Power is getting to it and the resistance of the coil is 12 Ohms which is about right (says 12V 13W so R should be 13 ohms)
Put a nail inside the coil and powered up and it does magnetise.

So presumably it is the valve itself. Typical now I have a tank of gas!
There is a cut off valve but I'm told they are not that reliable so I may have to vent off the gas.

The system is Milano, any suggestions where to get the parts? I'm in Swindon and Gas & Go don't have one. I also commute to Banbury so anywhere bewteen these locations?

Cheers


Top
 Profile  
 
PostPosted: Sun Jul 28, 2013 6:14 pm 
Intermediate Member

Joined: Wed Apr 09, 2008 9:00 am
Posts: 6836
Images: 0
Location: Peterborough
You may be able to persuade the solenoid to operate but hitting around it with a soft faced mallet, otherwise it'll need to come to bits to clean the gloop out of it. It might even be worth changing the multivalve, what make is the tank?

_________________
'96 Saab 900XS, AEB Leo, sold
'93 Range Rover 4.2 LSE, Lovato LovEco, sold
'98 Ex-Police Range Rover 4.0, Singlepoint AEB Leo, my daily motor
'97 Range Rover 4.0SE, eGas multipoint, a project.....

Proud to be a member of the YCHJCYA2PDTHFH club.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group